Mountain West Technologies - Chugwater Telephone Outage – Incident details

Chugwater Telephone Outage

Resolved
Partial outage
Started about 1 month agoLasted 12 days

Affected

Services

Partial outage from 10:27 PM to 3:18 PM

Voice

Partial outage from 10:27 PM to 3:18 PM

Internet

Operational from 10:27 PM to 3:18 PM

Platte County

Operational from 10:27 PM to 3:18 PM

Chugwater

Operational from 10:27 PM to 3:18 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. As of 10:40 p.m. March 25th, all calling features of Chugwater phones are fully functioning. If you are still experiencing problems, please call 307-233-8400 for tech support.

  • Monitoring
    Monitoring

    Since the Chugwater Telephone number is down, customers can call into 307-233-8400 to reach us.

  • Identified
    Identified

    We have repaired the ability for phones to call out, but incoming calls are still down. We are making progress on this repair.

  • Monitoring
    Monitoring

    We sincerely apologize for the inconvenience caused by the current phone service outage in Chugwater, Wyoming. Please be assured that our team is aware of the issue and is working diligently to restore service as quickly as possible.

     

    At this time, we do not have a definitive timeline for resolution. This outage is affecting landline customers only. Please visit our website at mwtn.net for updates.

     

    We appreciate your patience and understanding as we work to resolve this matter. Thank you for being a valued customer.

    Sincerely,       

    Chugwater Telephone Company

  • Identified
    Identified

    We are aware of an outage to phones in Chugwater, Wyoming. We are working to resolve the issue.