Chugwater Telephone Company Landline Maintenance (MWT-TID: 80089)
Scheduled for April 28, 2025 at 3:30 PM – 5:30 PM
Affects
The Chugwater Telephone Company
Under maintenance from 3:30 PM to 5:30 PM
Voice - Landline / POTS
Under maintenance from 3:30 PM to 5:30 PM
Completed
April 28, 2025 at 5:30 PMCompleted
April 28, 2025 at 5:30 PMMaintenance has completed successfully
In progress
April 28, 2025 at 3:30 PMIn progress
April 28, 2025 at 3:30 PMMaintenance is now in progress
Planned
April 28, 2025 at 3:30 PMPlanned
April 28, 2025 at 3:30 PMSummary of Work:
Chugwater Telephone Company will be implementing configuration changes in equipment at the Chugwater office.
This work is expected to disrupt voice traffic. During this time landline customers will be unable to make or receive phone calls.
Date and Time of Activity: Monday, April 28th, 2025 between 09:30 and 11:30 MDT
Physical Location of Activity: Chugwater, Wyoming
Services Affected:
- Voice (Chugwater, Wyoming)
Expected Down Time: 2 hours
Contact(s):
Mountain West Network Operations Center
noc@mwtcorp.net | 307-233-8400