Mountain West Technologies - Phase Loss - Casper Data Center (MWT-TID: 81007) – Incident details

Phase Loss - Casper Data Center (MWT-TID: 81007)

Resolved
Degraded performance
Started 21 days agoLasted about 3 hours

Affected

Mountain West Technologies

Degraded performance from 6:10 PM to 9:29 PM

Datacenters

Degraded performance from 6:10 PM to 9:29 PM

Casper

Degraded performance from 6:10 PM to 9:29 PM

Power Systems

Degraded performance from 6:10 PM to 9:29 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved after utilities located a failed component. Power was monitored for 15 minutes after they left the site and now is back in a normal state.

  • Monitoring
    Monitoring

    Our utility provider has dispatched additional crews and de-energized our utility service. Emergency power is being monitored and updates will be provided as they come.

  • Update
    Update

    Utility provider is on site and investigating, updates to follow when they are received.

  • Investigating
    Investigating

    We're currently investigating a loss of the C phase of our utility power service to our Casper Data Center. Utility provider has been notified and currently has a ETA of 30 minutes. Power has been transferred to emergency until the phase is restored.