Mountain West Technologies - Cheyenne Power Outage - Core Infrastructure (MWT-TID: 98201) – Incident details

Cheyenne Power Outage - Core Infrastructure (MWT-TID: 98201)

Resolved
Major outage
Started 7 days agoLasted about 2 hours

Affected

Mountain West Technologies

Major outage from 10:01 PM to 10:44 PM, Partial outage from 10:01 PM to 10:44 PM, Major outage from 10:44 PM to 12:16 AM, Degraded performance from 10:44 PM to 12:16 AM

Datacenters

Major outage from 10:01 PM to 12:16 AM

Cheyenne

Major outage from 10:01 PM to 12:16 AM

Environmental Systems

Major outage from 10:01 PM to 12:16 AM

Network Status

Major outage from 10:01 PM to 12:16 AM

Power Systems

Major outage from 10:01 PM to 12:16 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Colocation customers that may have had issues please reach out to noc@mwtcorp.net or 307-233-8400 so we can assist in restoration of services.

  • Identified
    Identified

    A utility power outage has impacted our Cheyenne data center, and our genset has failed to start. Wyoming Machinery is on site resolving this issue. Some services are still remaining on battery and are at risk. Updates will be provided as they are available.

  • Investigating
    Investigating
    We are currently investigating this incident.