Scheduled Maintenance - Carbon and Laramie County (MWT-TID:67822)

Completed
Scheduled for April 25, 2024 at 11:00 AM – 2:00 PM

Affects

Services
Internet
Carbon County
Encampment
Hanna
Medicine Bow
Updates
  • Completed
    April 25, 2024 at 2:00 PM
    Completed
    April 25, 2024 at 2:00 PM
    Maintenance has completed successfully
  • In progress
    April 25, 2024 at 11:00 AM
    In progress
    April 25, 2024 at 11:00 AM
    Maintenance is now in progress
  • Planned
    April 25, 2024 at 11:00 AM
    Planned
    April 25, 2024 at 11:00 AM

    During this time, our Engineering team will be completing an upgrade on routing devices that will impact customer services in Carbon and Laramie County. During this time internet and voice services may be partially, or completely unavailable for select subscribers.

    If you are experiencing issues after the completion time of 8:00 AM Thursday, April 25th please reach out to our support team at 307-233-8400 or support@mwtcorp.net.