Mountain West Technologies - E-Mail Server Failure (MWT-TID: 94401) – Incident details

Email experiencing partial outage

E-Mail Server Failure (MWT-TID: 94401)

Identified
Major outage
Started about 5 hours ago

Affected

Mountain West Technologies

Major outage from 12:04 AM to 1:35 AM, Partial outage from 1:35 AM to 12:00 AM

Services

Major outage from 12:04 AM to 1:35 AM, Partial outage from 1:35 AM to 12:00 AM

Email

Major outage from 12:04 AM to 1:35 AM, Partial outage from 1:35 AM to 12:00 AM

Updates
  • Identified
    UTC
    Identified

    We have identified a failure of our primary mail server. We have moved services to our backup server however, DNS records must update as mail fails over to it. This may take up to 12 hours but mail services are restoring.

  • Investigating
    UTC
    Investigating
    We are currently investigating this incident.