Mountain West Technologies - Mills > Alcova Outage | TID: 71631 – Incident details

Mills > Alcova Outage | TID: 71631

Resolved
Operational
Started 4 months agoLasted about 6 hours

Affected

Internet

Major outage from 8:21 PM to 8:54 PM, Partial outage from 8:21 PM to 8:54 PM, Major outage from 8:54 PM to 11:31 PM, Partial outage from 8:54 PM to 11:31 PM, Major outage from 11:31 PM to 12:05 AM, Partial outage from 11:31 PM to 12:05 AM, Operational from 12:05 AM to 2:39 AM

Natrona County

Major outage from 8:21 PM to 8:54 PM, Partial outage from 8:21 PM to 8:54 PM, Major outage from 8:54 PM to 11:31 PM, Partial outage from 8:54 PM to 11:31 PM, Major outage from 11:31 PM to 12:05 AM, Partial outage from 11:31 PM to 12:05 AM, Operational from 12:05 AM to 2:39 AM

Alcova

Major outage from 8:21 PM to 12:05 AM, Operational from 12:05 AM to 2:39 AM

Casper

Partial outage from 8:21 PM to 12:05 AM, Operational from 12:05 AM to 2:39 AM

Mills

Partial outage from 8:21 PM to 12:05 AM, Operational from 12:05 AM to 2:39 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Service is restored to all affected areas. We'll be monitoring for some time.

    If you are still experiencing service issues, please reach out to support@mwtcorp.net or 307-233-8400

  • Update
    Update

    Work continues to restore the damage. Updated estimated time of restoration is 10PM. Updated times and notices to follow as we continue to resolve this incident.

  • Identified
    Identified

    We've identified a fiber cut from a 3rd party and have a team engaged on recovery efforts. Our current estimated time of restoration is 6:00PM. Updates will follow.

  • Investigating
    Investigating

    We're currently investigating a outage affecting customers in parts of West Casper, Mills, and along 220 to Alcova. Teams are engaged. Updates to follow.