Mountain West Technologies - Partial Cole Creek Impacts (MWT-TID: 81061) – Incident details

Partial Cole Creek Impacts (MWT-TID: 81061)

Resolved
Partial outage 28 %
Started 18 days agoLasted 28 minutes

Affected

Mountain West Technologies

Partial outage from 10:05 PM to 10:32 PM

Internet

Partial outage from 10:05 PM to 10:32 PM

Natrona County

Partial outage from 10:05 PM to 10:32 PM

Evansville

Partial outage from 10:05 PM to 10:32 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently investigating impacts to a limited amount of customers in the Evansville Cole Creek area. Teams have been dispatched, and updates will follow shortly.