Mountain West Technologies - North Cheyenne Service Impact - MWT-TID: 87460 – Incident details

North Cheyenne Service Impact - MWT-TID: 87460

Resolved
Partial outage
Started 19 days agoLasted about 1 hour

Affected

Mountain West Technologies

Partial outage from 2:52 PM to 3:49 PM

Internet

Partial outage from 2:52 PM to 3:49 PM

Laramie County

Partial outage from 2:52 PM to 3:49 PM

Cheyenne

Partial outage from 2:52 PM to 3:49 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating service impacts to customers in select areas in North Cheyenne. Field teams are dispatched and will be onsite shortly.