Scheduled for January 26, 2026 at 8:30 PM – 8:38 PM
Affects
Mountain West Technologies
Under maintenance from 8:30 PM to 8:38 PM
Datacenters
Under maintenance from 8:30 PM to 8:38 PM
Casper
Under maintenance from 8:30 PM to 8:38 PM
Network Status
Under maintenance from 8:30 PM to 8:38 PM
Updates
Completed
January 26, 2026 at 8:38 PM
Completed
January 26, 2026 at 8:38 PM
Maintenance has completed successfully. Customers should see no lasting impact. If issues are discovered please contact dcsupport@mwtcorp.net or your normal support contact.
In progress
January 26, 2026 at 8:30 PM
In progress
January 26, 2026 at 8:30 PM
Maintenance is now in progress
Planned
January 26, 2026 at 8:30 PM
Planned
January 26, 2026 at 8:30 PM
Summary of Work:
During this time, Mountain West will be upgrading network elements that affect customers with shared colocation services in rack C2-1. These upgrades will add additional network connectivity options and ensure continued redundancy.
Customers may experience brief interface interruptions during the maintenance window. This impact is limited to shared colocation services only.