Mountain West Technologies - Emergency Power Risk - Casper Data Center (MWT-TID: 236734) – Incident details

Emergency Power Risk - Casper Data Center (MWT-TID: 236734)

Resolved
Degraded performance
Started 15 days agoLasted about 2 hours

Affected

Mountain West Technologies

Degraded performance from 12:53 PM to 2:26 PM

Datacenters

Degraded performance from 12:53 PM to 2:26 PM

Casper

Degraded performance from 12:53 PM to 2:26 PM

Power Systems

Degraded performance from 12:53 PM to 2:26 PM

Updates
  • Resolved
    Resolved

    Control wiring was reviewed and a loose relay was located. This with replaced as tested - emergency power is no longer at risk.

  • Update
    Update

    Genset service technicians have arrived onsite and are investigating.

  • Investigating
    Investigating

    We're currently investigating a fault condition on our emergency power generator at our Casper facility. Teams are engaged and will update shortly. This is an at-risk notification only, and no services are impacted at this time.